[personal profile] mjg59
A (well, now former) coworker let me know about a problem he was having with a Lenovo Thinkcentre M92p. It booted Fedora UEFI install media fine, but after an apparently successful installation refused to boot. UEFI installs on Windows worked perfectly. Secure Boot was quickly ruled out, but this could still have been a number of things. The most interesting observation was that the Fedora boot option didn't appear in the firmware boot menu at all, but Windows did. We spent a little while comparing the variable contents, gradually ruling out potential issues - Linux was writing an entry that had an extra 6 bytes in a structure, for instance[1], and a sufficiently paranoid firmware implementation may have been tripping up on that. Fixing that didn't help, though. Finally we tried just taking the Windows entry and changing the descriptive string. And it broke.

Every UEFI boot entry has a descriptive string. This is used by the firmware when it's presenting a menu to users - instead of "Hard drive 0" and "USB drive 3", the firmware can list "Windows Boot Manager" and "Fedora Linux". There's no reason at all for the firmware to be parsing these strings. But the evidence seemed pretty strong - given two identical boot entries, one saying "Windows Boot Manager" and one not, only the first would work. At this point I downloaded a copy of the firmware and started poking at it. Turns out that yes, actually, there is a function that compares the descriptive string against "Windows Boot Manager" and appears to return an error if it doesn't match. What's stranger is that it also checks for "Red Hat Enterprise Linux" and lets that one work as well.

This is, obviously, bizarre. A vendor appears to have actually written additional code to check whether an OS claims to be Windows before it'll let it boot. Someone then presumably tested booting RHEL on it and discovered that it didn't work. Rather than take out that check, they then addded another check to let RHEL boot as well. We haven't yet verified whether this is an absolute string match or whether a prefix of "Red Hat Enterprise Linux" is sufficient, and further examination of the code may reveal further workarounds. For now, if you want to run Fedora[2] on these systems you're probably best off changing the firmware to perform a legacy boot.

[1] src/include/efi.h: uint8_t padding[6]; /* Emperically needed */, says the efibootmgr source code. Unhelpful.
[2] Or Ubuntu, or Suse, or…

Confused as well

Date: 2012-12-10 09:36 pm (UTC)
From: [personal profile] xtalviper
So yeah, I too have a Lenovo K410 and spent two days of hair pulling before I gave up. I'm confused on the whole UEFI thing. First off, after reading thru forum stuff, someone said to look at some directory to see if it was booting via UEFI or not, and because I didnt see that (can't remember exactly now, it was last week) I figured it wasn't. However no matter what I did, Windows 7 just boots, and Ubuntu, or rather the Grub menu, never shows up. Someone said something about the partition table being GPT instead of MSDOS, so I even did that, changed it and wiped the disk, creating new partitions, starting all over, installing Win 7 and then Ubuntu, but same damn problem.

Because I see no "legacy" over UEFI options in the BIOS menu, I see I can't do that. How would I go about making this work for Ubuntu? (12.10 to be precise.)

Re: Confused as well

Date: 2012-12-20 06:30 am (UTC)
From: (Anonymous)
try this for the k410: go to bios>startup>enable csm>restart>access bios again>startup. you should be able to set it to legacy.

Re: Confused as well

Date: 2012-12-21 03:03 pm (UTC)
From: (Anonymous)
Yeah, there is no option there like that, in there or any other menues, I've looked. All that exists under startup menu is the primary boot order, quick boot, rapid boot, numlock and keyboardless operation options.

BIOS Info:

Revision Level: ECKT18A
Boot block revision level: EC18A
BIOS date: 05/08/12

Profile

Matthew Garrett

About Matthew

Power management, mobile and firmware developer on Linux. Security developer at Nebula. Member of the Linux Foundation Technical Advisory Board. Ex-biologist. @mjg59 on Twitter. Content here should not be interpreted as the opinion of my employer.

Page Summary

Expand Cut Tags

No cut tags